Documentation

PHP Version Requirements

WP Offload SES requires a minimum of PHP 5.5 as it uses the AWS PHP SDK v3.

Backup First!

If your PHP version needs to be upgraded, please make sure to backup your site’s files and database before making any configuration or software updates. It is extremely important to verify your backups before upgrading your site’s hosting platform. A backup is worthless if you can’t restore it, so be sure to try restoring it.

How to Upgrade PHP

If you have received a warning message from WP Offload SES that your site is running a version of PHP that will soon no longer be supported by WP Offload SES, please upgrade your server’s version of PHP as soon as possible.
There are many hosting providers and many ways to install and configure PHP, so it is impossible for us to guide you in how to upgrade your version of PHP.

If you are with a web hosting provider who manages the server for you, please contact them and ask them to migrate your site to a server with PHP version 7 or greater to ensure future compatibility with WP Offload SES.

If you have set up your own server, upgrading your version of PHP will very much depend on what operating system your server runs and how you have configured it. Please search for a comprehensive guide on how to upgrade PHP for your particular setup or engage the services of a professional server administrator to help you.